Cisco patches Aironet wireless vulnerabilities

IDG News Service |  Security

Network hardware giant Cisco Systems Inc. released a software patch and warned customers about two security holes that affect some editions of the Aironet wireless access point.

If left unpatched, the security vulnerabilities could enable an attacker to disable an Aironet access point in a denial of service attack, or coax user account information out of the device.

The security vulnerabilities were discovered by researchers at Vigilante.com Inc. and affect Cisco's 1100 Series access points, according to security advisories posted by Vigilante.com on Monday.

In one case, a vulnerability in certain versions of Cisco's Internetwork Operating System (IOS) for the Aironet 1100 series allows remote attackers to reboot the Aironet access point using a specially crafted URL (uniform resource locator), Vigilante.com said.

The vulnerability affects a number of different releases of IOS version 12.2, Cisco said. Repeated attacks on the access point using a vulnerable version of IOS would make it inaccessible, Cisco said. (See http://www.cisco.com/warp/public/707/cisco-sa-20030728-ap1x00.shtml.)

A second vulnerability in some versions of IOS could allow remote attackers to discover which user accounts exist on an affected access point, according to Cisco.

Attackers would have to use "brute force" approach to discovering the account names, connecting to the device using the common Telnet terminal emulation program, then attempting to log on by randomly guessing at the account name and password.

Depending on the type of response message returned by the access point for an invalid login, an attacker could conclude whether the account name they tried existed on the device.

Attackers could use the default account, named 'cisco,' with a bogus password to test the response of the access point and determine whether the device was running a vulnerable version of IOS.

Aironet access points running versions of IOS higher than version 11 are affected, Cisco said.

In its advisory Monday, the San Jose company released a list of more recent IOS releases that are not affected. (See http://www.cisco.com/warp/public/707/cisco-sn-20030724-ios-enum.shtml.)

Cisco offered customers workaround techniques for both problems, in addition to a software patch for the denial of service vulnerability.

For the account disclosure vulnerability, Cisco pointed customers to a variety of recent IOS releases that do not contain the vulnerability.

Join us:
Facebook

Twitter

Pinterest

Tumblr

LinkedIn

Google+

Join us:
Facebook

Twitter

Pinterest

Tumblr

LinkedIn

Google+

Ask a Question