Help with an old school apple 3G phone!!!

Answer

landon
Vote Up (14)

iTunes is probably just going to keep trying to install a new version of iOS that a 3G will not support. I'm speculating about this, so don't accept it as gospel. Maybe the easiest thing for him to do would be to go to the Apple Store, if there is one around, and see if they can install an older version of iOS. I think 4.2 is the most current version that a 3G will support. 

Join us:
Facebook

Twitter

Pinterest

Tumblr

LinkedIn

Google+

Ask a Question