maintainers to reset user passwords, change SSL certificate

The compromise extended to two servers, the PHP Group said


The PHP Group will reset the passwords for accounts on, the official website of the PHP programming language, and will change the site's SSL certificate after attackers compromised two servers and injected malicious code into the website.

The security breach was confirmed Thursday after earlier in the day the Google Safe Browsing service blacklisted the site for distributing malware ,which caused Mozilla Firefox and Google Chrome to block users from visiting it.

The PHP Group initially thought the warnings were the result of a false positive detection, but a more thorough investigation revealed that attackers managed to inject malicious JavaScript code into one of the site's files called userprefs.js. That code executed exploits from a third-party website that, if successful, installed a piece of malware on visitors' computers.

The PHP Group's investigation, which is still in progress, revealed that the compromise extended to two servers: the server that hosted the, and domains and the server that hosted, the project's bug tracking system.

There is no evidence that the PHP distribution packages or the Git repository used for source code management have been compromised.

"All affected services have been migrated off those servers," the PHP Group said in a status update. "We have verified that our Git repository was not compromised, and it remains in read only mode as services are brought back up in full."

The method used by attackers to compromise the two servers and inject rogue code into userprefs.js has yet to be determined. users who contribute to different projects hosted on or will have their passwords reset, the PHP Group said.

In addition, the SSL certificate used on several websites has been revoked, because it's possible that attackers might have gained access to the certificate's private key.

"We are in the process of getting a new certificate, and expect to restore access to sites that require SSL (including and in the next few hours," the PHP Group said.

Users who visited the affected websites between Oct. 22 and Oct. 24 should scan their computers for malware.

The malicious code was only intermittently served to users during that time because an existing synchronization process was periodically reverting the userprefs.js to its original clean state. As a result, not all visitors were affected, but it's hard to know which ones were.

According to security researchers from Alien Vault, the malicious code on loaded an instance of the Magnitude exploit kit hosted on a different website. Exploit kits are Web-based attack tools that exploit vulnerabilities in browser plug-ins to infect computers with malware. attack traffic captured by researchers from Barracuda Networks on Tuesday contained a Flash Player exploit, but according to researchers from Trustwave an exploit for the CVE-2013-2551 vulnerability, which affects Internet Explorer versions 6 to 10, was also used. This vulnerability was patched by Microsoft in May.

Kaspersky Lab senior security researcher Fabio Assolini said on Twitter that if successful, the exploits installed a Trojan program called Tepfer.

The Tepfer malware is designed to steal log-in credentials and configuration information from FTP client software, according to an August analysis by researchers from Fortinet.

Many users who visit the website are Web developers and they are likely to store FTP log-in credentials on their computers for the websites they maintain. Users who believe they might have been compromised as a result of this attack should probably change the log-in credentials stored in their FTP clients.

Now Read This: IT Resume Makeover: Our top 11 tips
View Comments
You Might Like
Join the discussion
Be the first to comment on this article. Our Commenting Policies