Nokia Lumia 900 bug nixes data connections

Some of Nokia's Lumia 900 phones, which launched on April 8, are having trouble connecting to AT&T's data network.

Maybe Nokia spoke too soon when it said the "smartphone beta test is over."

Some of Nokia's Lumia 900 phones, which launched on April 8, are having trouble connecting to AT&T's data network. As Electronista points out, users are complaining about the issue on Nokia's discussion forums and WPCentral. Dwight Silverman, a tech writer for the Houston Chronicle, also had connection problems with his review unit, which had to be replaced.

An unnamed source, who reportedly works for AT&T, told Phone Arena that some phones' International Mobile Equipment Identity numbers are failing to register with the AT&T's data network. The carrier and Nokia are removing defective devices from store shelves, the source said, but AT&T and Nokia have not publicly confirmed the problems.

Some forum users are suggesting that users should remove the Lumia 900's SIM card, perform a master reset, reboot the phone, turn off the device, then reinsert the SIM card and boot up again. Other users say this method doesn't permanently fix the problem.

I doubt this is a huge setback for Nokia's latest Windows Phone, especially if AT&T is no longer selling Lumia 900 phones that have data problems, but it is ironic given Nokia's ad campaign for the phone, which tries to paint Apple's iPhone as a beta product. As it turns out, some of the Lumia 900's early adopters are playing guinea pig.

Follow Jared on Twitter, Facebook or Google+ for even more tech news and commentary.

This story, "Nokia Lumia 900 bug nixes data connections" was originally published by PCWorld.

What’s wrong? The new clean desk test
Join the discussion
Be the first to comment on this article. Our Commenting Policies