OSPF over Frame-Relay - Part 2: Broadcast

http://ipexpert.ccieblog.com/ – In part I of our series, we looked at the default OSPF network type on frame-relay (non-broadcast). This begs the question of “OK we know non-broadcast, now what about broadcast?” Excellent, let’s get started!

First, I want to get into actually understanding the technology. This is important because once you get the concepts, you should not have to straight up memorize the important pieces. You will be able to build them on your own.

So, what is the broadcast network type, and what are its attributes? When I think of a broadcast network type I immediately think of Ethernet. This is actually a great example, because the default OSPF type on an Ethernet topology is broadcast. So what happens on Ethernet with respect to OSPF? Well, we have a DR right? That makes sense because we can have a whole bunch of routers on a single Ethernet segment and we don’t want to have to peer between all of them. We just elect a single DR to do all the dirty work. Secondly, our OSPF packets are sent via multicast to 224.0.0.5 and 224.0.0.6. This is perfect on Ethernet because it is a broadcast medium. What about frame-relay?

Well, the concept of the DR does not change at all! We still need it, and we will take care of that exactly as we did in the non-broadcast article - make the hub the DR by setting it to a higher priority. Make sure your spokes can NEVER be the DR/BDR by setting their priority to 0. So nothing magical there.

What about OSPF traffic? With non-broadcast we had to resort to unicast messages using the neighbor command. We said frame-relay was a non-broadcast medium by nature. So what do we do? Well, in my mind this is sort of a “hack” which always makes things a bit more exciting J In frame-relay, when you are doing your layer 3 to layer 2 resolution (using frame-map usually) you can specify the broadcast keyword on the end of your map.

For example: frame-relay map ip 100.100.100.5 205 broadcast

What does this do? It is actually pretty clever. What this does is tell the routers “Hey if you have any broadcast messages, go ahead and send them down this DLCI as a unicast” So basically it is a way to send broadcast messages on a non-broadcast medium J

With that being said it is VITALLY important that you have the broadcast keyword on your frame maps on both sides, or this will not work!!! That is really as complex as the broadcast network type over frame gets! What about timers? Well, think about broadcast. Most broadcast environments like Ethernet are generally considered “fast” so we use fast timers! This means our hello/dead timers will be 10/40 seconds by default.

Let’s set this up and see how things work out. I have gone ahead and done “no router ospf 1″ on all our frame routers in the topology. We will set things up from scratch.

First, we set our DR priority and our network type on the interface! Then we will setup basic OSPF.

R2(config)#int s0/1/0.256

R2(config-subif)#ip ospf pri 255

R2(config-subif)#ip ospf network broad

R2(config-subif)#router ospf 1

R2(config-router)#network 100.100.100.2 0.0.0.0 area 0

R5(config-if)#ip ospf pri 0

R5(config-if)#ip ospf network broadcast

R5(config-if)#

R5(config-if)#router ospf 1

R5(config-router)#network 100.100.100.5 0.0.0.0 area 0

R6(config)#int s0/1/0

R6(config-if)#ip ospf pri 0

R6(config-if)#ip ospf network broadcast

R6(config-if)#

R6(config-if)#router ospf 1

R6(config-router)#network 100.100.100.6 0.0.0.0 area 0

Taking a look here at R6 we can see that the OSPF network type is indeed broadcast, our timers are “fast”, it has a neighbor to R2 who is the DR, and that we have enabled broadcast on our frame maps

R6(config-router)#do sh ip ospf int s0/1/0 | i Network Type|Timer

Process ID 1, Router ID 100.100.100.6, Network Type BROADCAST, Cost: 64

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

R6(config-router)#do sh ip ospf neigh

Neighbor ID Pri State Dead Time Address Interface

100.100.100.2 255 FULL/DR 00:00:31 100.100.100.2 Serial0/1/0

R6(config-router)#do sh run int s0/1/0

Building configuration…

Current configuration : 295 bytes

!

interface Serial0/1/0

ip address 100.100.100.6 255.255.255.0

encapsulation frame-relay

ip ospf network broadcast

ip ospf priority 0

frame-relay map ip 100.100.100.2 602 broadcast

frame-relay map ip 100.100.100.5 602

frame-relay map ip 100.100.100.6 602

no frame-relay inverse-arp

end

That’s it for OSPF broadcast over frame-relay. Let’s review. First, in order to have broadcasts on an OSPF network, we need to make sure to set the broadcast keyword on our frame maps. Secondly, broadcast still requires the use of a DR so make sure your hub is set as the DR by using the priority command on the interface. OSPF network types are set on the interface level. Finally, our timers by default are “fast” 10 hello/40 dead.

In our next installment we will take a look at the fairly simple point-to-point OSPF network type! Stay tuned for more tutorials covering all the different OSPF network types.

Thanks!

Joe (Post contributed by Joe Astorino - CCIE #24347 R&S)

Insider: How the basic tech behind the Internet works
Join the discussion
Be the first to comment on this article. Our Commenting Policies