Microsoft plugs BizTalk Server holes

Microsoft Corp. warned of a security flaw in its BizTalk Server enterprise integration product that could allow an attacker to take over systems running the product.

The flaw exists in the document tracking and administration Web site that is part of both BizTalk Server 2000 and BizTalk Server 2002. Several of the site's pages do not correctly validate input strings, exposing the system to attacks, Microsoft said in security bulletin MS03-016 released Wednesday. (See: http://www.microsoft.com/technet/security/bulletin/MS03-016.asp .)

An attacker could gain full control over the system running the BizTalk Server software by crafting a hyperlink containing malicious SQL commands and tricking a BizTalk Server user to follow that link. The commands would run on the server with the same level of permissions as the user, Microsoft said.

A second vulnerability only affects BizTalk Server 2002. A flaw exists in the HTTP (Hypertext Transfer Protocol) Receiver used for exchanging documents using HTTP. By sending a malformed request to the HTTP Receiver, an attacker can cause a buffer overrun and run code of his choice on the server, Microsoft said.

One of BizTalk Server's primary functions is to transfer business documents between back-end business systems. HTTP is one of several document-receive functions; others include File Transfer Protocol (FTP) and SMTP (Simple Mail Transfer Protocol). The HTTP Receiver is not enabled by default, Microsoft said.

Microsoft on Wednesday also reissued a patch for Windows Server 2000 Terminal Server Edition originally released in security bulletin MS02-071 in December last year. An error in the installer for the earlier patch meant that the correct files were not being copied on to multi-processor systems, causing them to fail under certain scenarios, Microsoft said in a revised version of its bulletin. (See: http://www.microsoft.com/technet/security/bulletin/MS02-071.asp.)

This is the second time Microsoft has had to reissue a patch for the same issue; the first version caused the NT 4.0 operating system to fail. The patch fixes a vulnerability affecting the WM_TIMER function. By taking advantage of the flaw, an attacker with logon credentials for the system could gain full administrative privileges on a vulnerable system, Microsoft said.

Top 10 Hot Internet of Things Startups
Join the discussion
Be the first to comment on this article. Our Commenting Policies