USENIX: Unstable code can lead to security vulnerabilities