Researcher digs up another zero-day Java bug

Present in Java 5. 6 and 7, leaves Windows PCs and Macs open to attack

By , Computerworld |  Security, java

A security researcher known for finding Java bugs has uncovered a new critical zero-day vulnerability in all currently-supported versions of the popular Oracle software.

The bug, which was publicly reported on the Full Disclosure security mailing list Tuesday by Adam Gowdiak, the founder and CEO of Polish security firm Security Explorations, can be leveraged to hijack a machine equipped with Java, letting attackers install malware on the system.

Windows PCs and Macs are equally at risk if their users have installed Java, or in the case of OS X, are running 10.6, aka Snow Leopard, or earlier. Snow Leopard was the last edition where Apple bundled Java with the operating system.

All currently-support versions of Java, including Java 5, Java 6 and Java 7, contain the bug.

Gowdiak has found other Java vulnerabilities in the past: Earlier this year he reported more than a dozen to Oracle. Months later, hackers independently uncovered one of the bugs, then began using it in widespread attacks during August.

On Aug. 30 Oracle shipped one of its rare emergency, or "out-of-band," security updates to patch the exploited Java bug.

The vulnerability Gowdiak revealed Tuesday was both potentially more serious than the already-exploited flaw and less of a risk to users at the moment.

"The potential impact is bigger when it comes to the number of Java desktops," said Gowdiak in an email reply to questions. "The vulnerability affects up-to-date installs of Java 5, 6 and 7. We even tested the developer preview of Java 7 Update 10, a build from Sept. 20, 2012, [and] verified it was also vulnerable."

The Java zero-days exploited by cyber criminals last month were in Java 7 only -- the newest edition -- and because of that, Gowdiak and other experts recommended users downgrade to Java 6, which was safe.

Not the case now, as all editions of Java harbor the flaw.

Gowdiak, using installed-base statistics cited by Oracle, argued that approximately 1 billion computer users are at risk because of the unpatched vulnerability.

On the other hand, there is much less urgency with this vulnerability than the one exploited last month for the simply fact that there's no evidence it's in the hands of hackers. "We are not aware of any active attacks that would exploit this vulnerability," Gowdiak said.


Originally published on Computerworld |  Click here to read the original story.
Join us:
Facebook

Twitter

Pinterest

Tumblr

LinkedIn

Google+

Answers - Powered by ITworld

ITworld Answers helps you solve problems and share expertise. Ask a question or take a crack at answering the new questions below.

Join us:
Facebook

Twitter

Pinterest

Tumblr

LinkedIn

Google+

Ask a Question