Adobe patches critical vulnerabilities in Flash Player, ColdFusion

The vulnerabilities could allow unauthorized remote code execution or remote read access

By Lucian Constantin, IDG News Service |  Security

Adobe Systems released security updates for Flash Player, AIR and ColdFusion to fix critical vulnerabilities that could allow attackers to take control of affected systems or read information from servers without authorization.

The updates for Flash Player and Adobe AIR, an Internet rich application runtime with Flash support, fix two memory corruption vulnerabilities that could lead to remote code execution.

Adobe recommends that users update to Flash Player version 11.9.900.152 for Windows and Mac and version 11.2.202.327 for Linux. The Flash Player version bundled with Google Chrome, Internet Explorer 10 on Windows 8 and Internet Explorer 11 on Windows 8.1 will be automatically updated through the update mechanisms of those browsers, the company said in an advisory.

Windows, Mac and Android users of Adobe AIR and Adobe AIR SDK (software development kit) should update to version 3.9.0.1210 of those programs.

Adobe also released security hotfixes for versions 10, 9.0.2, 9.0.1 and 9.0 of its ColdFusion application server. Those patches address a critical vulnerability that could allow remote, unauthenticated attackers to read information from a vulnerable server and a reflected cross-site scripting (XSS) whose exploitation requires authentication.

ColdFusion servers have been targeted by attackers in the past. In January, Adobe warned customers that attackers were exploiting unpatched vulnerabilities in ColdFusion and in April hackers broke into the management servers and customer database of Linode, a virtual private server hosting firm, by exploiting a previously unknown ColdFusion vulnerability.

Adobe is not aware of any exploits or attacks that are actively targeting the vulnerabilities fixed in the new security updates and does not believe the vulnerabilities are related to the theft of source code the company announced at the beginning of October, Adobe spokeswoman Heather Edell said via email.

On Oct. 3, Adobe announced that hackers broke into its internal network and stole the source code of Adobe Acrobat, ColdFusion, ColdFusion Builder and other products. Security researchers said at the time that the source code leak might help attackers find vulnerabilities in the affected products.

Join us:
Facebook

Twitter

Pinterest

Tumblr

LinkedIn

Google+

Answers - Powered by ITworld

Join us:
Facebook

Twitter

Pinterest

Tumblr

LinkedIn

Google+

Ask a Question