
<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
<!-- ad-related js -->
<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
<script src="/www/js/init_device.js"></script>
<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20180313113117"></script>
<script type="text/javascript">if(adLayer==null||adLayer=='undefined'){var adLayer=[];}adLayer["itemType"]="article";</script>
<script type="text/javascript">try{IDG.GPT.unitName="/8456/IDG.US_E_ITworld.com";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.unitName=IDG.GPT.unitName+"/"+"open-source-tools_section";}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}var global_ShowSuper=true;var global_ShowHero=false;var url=window.location.href;if(url.indexOf("?")>1){url=url.split('?')[0];}try{IDG.GPT.addTarget("URL",encodeURIComponent(url));}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("zone",'article');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("chan",'cloud-computing');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("articleId",'3261450');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("type",'feature');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("typeId",'6');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("manufacturer",'sony');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("templateType",'article-default');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categoryIds",[4045,3808,3248,3646,3255]);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("categorySlugs",['open-source-tools','development','cloud-computing']);}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{if(null!=IDG.GPT.getQsVal("env")){IDG.GPT.addTarget("env",IDG.GPT.getQsVal("env").replace(/\W/g,""));}}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("author",'Serdar Yegulalp');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("page_type",'');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("tagNames",'Kubernetes,Docker');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}try{IDG.GPT.addTarget("insiderContent",'false');}catch(exception){console.log("google_dfp can't use IDG.GPT "+exception);}</script>
<script type="text/javascript"></script>
<script src="/www.idge/js/thm_pre.js?v=20180313113117"></script>
<script type="text/javascript">(function(){try{var proximic_data={"data":["300003","121100","112200","112202","131100","131112","240000","240002","240003","240004","240001","240005","240006","240007","240008","240009","240011","240012","240013","240014","240017","240015","240016","4caxri","20f4sh","bkwp85","enwcef","w601py","bsuu95","x8eev1","9v0tiu","1o8fv9","32xt66","skl8g2","8ug70v","li8svo","e2co9k","r03wnl","folvaf","6vexzx","pytywb","kcyvgz","44ywyv","xks7sj","yn3dkv","agtqg7","7grvv1","agt9m3","240saz","pcz604","itgwkk","500085","500009","500082","500102","500022","500017","500033","500190","500034","500202","500198","500187","500220","500234","500226","500230","500224","500221","500218","500247","500235","500233","500238","500241","500219","500223"]};IDG.GPT.addTarget("proximic",proximic_data.data);}catch(e){console.log("Error: "+e);}})();</script>
<script>var isMobile=(typeof IDG.DEVICE!=='undefined')?IDG.DEVICE.isMobile():false;try{IDG.GPT.disableInitialLoad=true;IDG.GPT.addBiddingParams("yieldbotPsn",(isMobile?"7df3":"f509"));IDG.GPT.addBiddingParams("appnexusPlacementId",(isMobile?"6451438":"6353139"));IDG.GPT.addBiddingParams("TriLiftPrefix","itworld_ros_");}catch(e){console.log("Error in adding bidding params: "+e);}</script>
<script src="/www/js/ads/narf_prebid.js?v=20180313113117"></script>
<script type="text/javascript" src="/www/js/ads/gpt_starter.js"></script>
<script type="text/javascript" src="/www/js/ads/gpt_launcher.js"></script>
<!-- metas -->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>10 tools to make Kubernetes management easier | ITworld</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="canonical" href="https://www.infoworld.com/article/3261450/containers/10-tools-to-make-kubernetes-management-easier.html"/>
<meta itemprop="url" content="https://www.itworld.com/article/3261450/containers/10-tools-to-make-kubernetes-management-easier.html"/>
<meta name="description" content="Take advantage of these third-party projects to simplify Kubernetes app definitions, enhance the CLI and monitoring, and ease AWS cloud deployments"/>
<meta name="DC.date.issued" content="2018-03-14T03:00-05:00"/>
<meta name="date" content="2018-03-14"/>
<link rel="amphtml" href="https://www.itworld.com/article/3261450/containers/10-tools-to-make-kubernetes-management-easier.amp.html"/>
<meta property="og:title" content="10 tools to make Kubernetes management easier">
<meta property="og:description" content="Take advantage of these third-party projects to simplify Kubernetes app definitions, enhance the CLI and monitoring, and ease AWS cloud deployments">
<meta property="og:image" content="https://images.idgesg.net/images/article/2018/01/survival_life-preserver_risk_swimming_rescue-100747102-large.3x2.jpg"/>
<meta property="og:image:width" content="700"/>
<meta property="og:image:height" content="467"/>
<meta itemprop="image" content="https://images.idgesg.net/images/article/2018/01/survival_life-preserver_risk_swimming_rescue-100747102-large.3x2.jpg">
<meta itemprop="thumbnailURl" content="https://images.idgesg.net/images/article/2018/01/survival_life-preserver_risk_swimming_rescue-100747102-large.3x2.jpg"/>
<link rel="image_src" href="https://images.idgesg.net/images/article/2018/01/survival_life-preserver_risk_swimming_rescue-100747102-large.3x2.jpg"/>
<meta name="twitter:image" content="https://images.idgesg.net/images/article/2018/01/survival_life-preserver_risk_swimming_rescue-100747102-large.3x2.jpg"/>
<meta property="og:type" content="article"/>
<meta name="author" content="Serdar Yegulalp">
<meta property="og:site_name" content="ITworld"/>
<meta property="fb:app_id" content="123026274413041"/>
<meta property="og:url" content="https://www.itworld.com/article/3261450/containers/10-tools-to-make-kubernetes-management-easier.html">
<!-- Use Twitter Summary Card with Large Image for articles and videos -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@itworld">
<meta name="twitter:description" content="Take advantage of these third-party projects to simplify Kubernetes app definitions, enhance the CLI and monitoring, and ease AWS cloud deployments">
<meta name="rating" content="General">
<meta name="robots" content="NOODP,NOYDIR"/>
<meta name="msvalidate.01" content="B6D65511A0CC5522E695818081C251B8"/>
<!-- Sailthru -->
<meta name="sailthru.tags" content="open-source-tools,development,cloud-computing,kubernetes,docker,serdar-yegulalp,feature,medium"/>
<meta name="sailthru.image.thumb" content="https://images.idgesg.net/images/article/2018/01/survival_life-preserver_risk_swimming_rescue-100747102-small.jpg"/>
<meta name="sailthru.image.full" content="https://images.idgesg.net/images/article/2018/01/survival_life-preserver_risk_swimming_rescue-100747102-large.3x2.jpg"/>
<meta name="sailthru.title" content="10 tools to make Kubernetes management easier"/>
<meta name="sailthru.description" content="Take advantage of these third-party projects to simplify Kubernetes app definitions, enhance the CLI and monitoring, and ease AWS cloud deployments"/>
<meta name="displaytype" content="article"/>
<meta name="source" content="infoworld"/>
<meta name="category" content="containers,devops,open source,software development,cloud computing"/>
<meta name="storytype" content="feature"/>
<meta name="tags" content="kubernetes,docker"/>
<!-- pagination -->
<link id="mobile-size" rel="stylesheet" href="/www.idge/css/inline-header-mobile.css?v=20180313113117"/>
<script>if(window.matchMedia("(min-width: 768px)").matches){document.getElementById('mobile-size').insertAdjacentHTML('afterend','<link id="desktop-size" rel="stylesheet" href="/www.idge/css/inline-header.css?v=20180313113117" />');}</script>
<link rel="stylesheet" href="/www.idge.itw/css/inline-header.css?v=20180313113117"/>
<!-- css -->
<link rel="stylesheet" href="/www.idge/css/normalize.css"/>
<link rel="stylesheet" href="/www.idge/css/prettify.css"/>
<link rel="stylesheet" href="/www.idge.ans/js/select2-3.5.0/select2.css"/>
<link rel="stylesheet" href="/www/css/article.css?v=20180313113117"/>
<link rel="stylesheet" href="/www.idge/css/print.css" media="print"/>
<link rel="stylesheet" href="/www.idge.itw/css/article.css?v=20180313113117"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css"/>
<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css"/>
<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->
<script type="text/javascript" src="//fonts.staticworld.net/ylv4wjj.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
<!--  fav and touch icons -->
<link rel="shortcut icon" type="image/x-icon" href="https://idge.staticworld.net/itw/favicon.ico"/>
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://idge.staticworld.net/itw/ITworld-logo144x144.png"/>
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://idge.staticworld.net/itw/ITworld-logo114x114.png"/>
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://idge.staticworld.net/itw/ITworld-logo72x72.png"/>
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://idge.staticworld.net/itw/ITworld-logo57x57.png"/>
<link rel="apple-touch-icon" href="https://idge.staticworld.net/itw/ITworld-logo300x300.png"/>
<!-- LiveRamp Sources -->
<script type="text/javascript" src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
<script src="/www/js/utils/liveRamp.js"></script>
<!-- End of LiveRamp -->
<script src="/www.idge.ans/js/select2-3.5.0/select2.js"></script>
<script>$(document).ready(function(){$("select#country").select2({placeholder:"country",minimumResultsForSearch:Infinity,allowClear:true});$("#jobPosition").select2({placeholder:"position",minimumResultsForSearch:Infinity,allowClear:true});$("#jobFunction").select2({placeholder:"function",minimumResultsForSearch:Infinity,allowClear:true});$("#companySize").select2({placeholder:"company size",minimumResultsForSearch:Infinity,allowClear:true});$("#industry").select2({placeholder:"industry",minimumResultsForSearch:Infinity,allowClear:true});});</script>
<script>var brandCode="itw";var brandName="ITworld";var regDebugLog=false;var regApiUrl="https://regdev.idge.int/api/";var tokenPrefix='www';var tokenSuffix='.com/insider/token?';var brandDomain=".itworld.com";var insiderContentType="article";var notEmptyArticle=false;var notEmptyMediaResource=false;var isInsiderPremium=false;var isResourceInsiderPremium=false;regApiUrl="https://reg.idgenterprise.com/api/";regDebugLog=false;tokenPrefix="http://www";tokenSuffix="/insider/token";notEmptyArticle=true;</script>
<script src="/www/js/utils/alc_hashes.js"></script>
<script src="/www/js/insider/insider_reg_api.js?v=20180313113117"></script>
<script src="/www/js/insider/jquery.maskedinput-1.4.min.js"></script>
<script>$(document).ready(function(){if(typeof(IDG.insiderReg.readCookie('nsdr'))!=='undefined'){$('#welcome-message').show();IDG.insiderReg.personalize();}else{$('.signin-register').show();}});</script>
<!-- Begin Eloqua Tracking -->
<script type="text/javascript" src="/www/js/analytics/eloqua/elqCfg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqImg.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqFCS.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqScr.js"></script>
<script type="text/javascript" src="/www/js/analytics/eloqua/elqIDG.js"></script>
<script type="text/javascript">IDG=window.IDG||{};IDG.PageInfo=IDG.PageInfo||{};IDG.PageInfo=function(){return{eloqua_type:"article",eloqua_topic:""};}();var elqCustomerGUID="";if(this.GetElqCustomerGUID&&typeof GetElqCustomerGUID==="function"){elqCustomerGUID=GetElqCustomerGUID();}IDG.Eloqua.invoke_flash();</script>
<!-- End Eloqua Tracking -->
<script type="text/javascript">var g_arrModules=new Array();</script>
<meta name="parsely-title" content="10 tools to make Kubernetes management easier"/>
<meta name="parsely-link" content="https://www.itworld.com/article/3261450/containers/10-tools-to-make-kubernetes-management-easier.html"/>
<meta name="parsely-type" content="NewsArticle"/>
<meta name="parsely-image-url" content="https://images.idgesg.net/images/article/2018/01/survival_life-preserver_risk_swimming_rescue-100747102-large.3x2.jpg"/>
<meta name="parsely-pub-date" content="2018-03-14T10:00:00Z"/>
<meta name="parsely-section" content=""/>
<meta name="parsely-author" content="Serdar Yegulalp"/>
<meta name="parsely-tags" content="Kubernetes,Docker,type: feature,source: infoworld,imported"/>
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
<script src="/www/js/ads/ads.js"></script>
<!-- Adding articleHasVideo value in datalayer-->
<script>var insiderSignedIn=document.cookie.indexOf("nsdr")>-1;var dlJobFunction='';var dlJobPosition='';var dlIndustry='';if(insiderSignedIn){var insiderToken=IDG.insiderReg.readCookie("nsdr");var tokens=IDG.insiderReg.readCookieProperty(insiderToken);if(!(tokens['jobPosition']===undefined)){dlJobPosition=tokens['jobPosition'];}if(!(tokens['jobFunction']===undefined)){dlJobFunction=tokens['jobFunction'];}if(!(tokens['industry']===undefined)){dlIndustry=tokens['industry'];}}insiderSignedIn=insiderSignedIn.toString();var sincePublished='0 days';sincePublished=sincePublished.split(" ")[0];dataLayer=[{'articleId':'3261450','articleDisplayId':'1','articleTitle':'10 tools to make Kubernetes management easier','articleType':'Feature','audience':'enterprise','author':'Serdar Yegulalp','blogName':'','brandpost':'false','categoryIdList':'4045,3808,3248,3646,3255','categoryIdPrimary':'3248','contentStrategy':'','contentType':'feature','datePublished':'2018-03-14','dateUpdated':'','daysSincePublished':sincePublished,'daysSinceUpdated':'','displayType':'article','environment':'production','ga_enabled':'true','gaTrackingId':'UA-300704-7','geolocEnabled':'true','industry':dlIndustry,'insiderSignedIn':insiderSignedIn,'isBlog':'false','isInsiderContent':'false','isICN':'false','jobFunction':dlJobFunction,'jobPosition':dlJobPosition,'pageNumber':'1','parselyEnabled':'true','parselyDomain':'itworld.com','platform':'Web','primaryCategory':'','primaryCategoryList':'containers,devops,open source,software development,cloud computing','property':'itworld','propertyCountry':'US','purchaseIntent':'awareness','sailthruCustomerId':'768c53190537081f2e79316ca327d876','skimlinksId':'111346X1569478','source':'infoworld','sponsorName':'','tags':'kubernetes,docker','videoAutoplay':'false','articleHasVideo':'false'}];</script>
<script type="text/javascript">var _sf_async_config={};_sf_async_config.uid=29363;_sf_async_config.path="/article/3261450/containers/10-tools-to-make-kubernetes-management-easier.html";_sf_async_config.title="10 tools to make Kubernetes management easier | ITworld";_sf_async_config.domain="itworld.com";if(window.location.href.indexOf("video")&&true){_sf_async_config.playerdomain=_sf_async_config.domain.replace("www.","");}_sf_async_config.useCanonical=true;_sf_async_config.authors="Serdar Yegulalp";</script>
<script>var dataLayer=window.dataLayer=window.dataLayer||[];var adBlockStatus='false';function AdBlockEnabled(){var ad=document.createElement('ins');ad.className='AdSense';ad.style.display='block';ad.style.position='absolute';ad.style.top='-1px';ad.style.height='1px';if(document.body!=null){document.body.appendChild(ad);var isAdBlockEnabled=!ad.clientHeight;document.body.removeChild(ad);}return isAdBlockEnabled;}if(AdBlockEnabled()!=undefined){adBlockStatus=AdBlockEnabled().toString();}if(document.body==null){if(window.canRunAds===undefined){adBlockStatus='true';}else{adBlockStatus='false';}}dataLayer.push({'adBlockStatus':adBlockStatus});</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-TP6NS4" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-TP6NS4');</script>
<!-- End Google Tag Manager -->
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
</head>
<body id="article3261450" class="article itworld">
<!-- Begin welcome ad overlay - gpt-overlay position  -->
<div id="superadunit" class="hidden">
<div class="ad">
<div class="ad-header">
<div class="brand-logo"></div>
<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
</div>
<div id="gpt-overlay" class=" ad-container">
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-overlay","true");IDG.GPT.displayGoogleTagSlot('gpt-overlay');</script>
</div>
</div>
</div>
<!--  End welcome ad overlay - gpt-overlay position -->
<!-- BEGIN PAGE HEADER -->
<header id="banner">
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.main-header').insertBefore($('#banner .ad'));}</script>
<div class="topics-wrap">
<section class="topics">
<nav id="scrollable">
<!-- blx4 #1147 blox4.raw_link_list  -->
<ul>
<li class="header">Trending<span class="colon">:</span></li>
<li><a href="/news/">News</a></li>
<li><a href="/about/sitemap.html">All topics</a></li>
<li><a href="/video/">Video</a></li>
<li><a href="/slideshows/">Slideshows</a></li>
<li><a href="/dealpost/">Deals</a></li>
<li><a href="https://shop.itworld.com/deals/online-courses" target="_blank" rel="nofollow">Online Courses</a></li>
<li><a href="/newsletters/signup.html">Newsletter</a></li>
<li><a href="/resources/">Resources/White Papers</a></li>
</ul>
</nav>
<div class="fading-gradient"></div>
<nav class="tools">
<ul class="user">
<li class="search-icon"><a href="#search" id="search-btn"><i class="ss-icon">Search</i></a></li>
</ul>
<ul class="social">
<li><a href="https://twitter.com/itworld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="http://www.linkedin.com/company/659366" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="https://www.facebook.com/itworld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/+ITworld/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
<li class="more-social"><i class="ss-icon ss-ellipsis"></i></li>
</ul>
</nav>
</section>
</div>
<div id="sticky-anchor"></div>
<section id="sticky-head" class="main">
<div class="wrapper">
<div class="masthead">
<button><i class="ss-icon ss-rows"></i></button>
<a href="/"><span class="ir logo">itworld</span></a>
<!--
	            	<img class="print-only" src="/www.idge.itw/images/itworld-logo-print.png">
	            	-->
<img class="print-only" src="//idge.staticworld.net/itw/itworld-logo-print.png">
</div>
<div id="reading-tools-wrapper">
<nav class="tools">
<ul class="user">
</ul>
</nav>
</div>
</div>
</section>
<section class="tools-expand  ">
<form class="search" id="search-form" action="/search">
<label for="search-box">Search for</label>
<input type="text" name="query" id="banner-search-term" value="" class="searchbox-input-class"/>
<input type="submit" id="banner-search-submit" value="Go"/>
<input type="hidden" name="contentType" value="article,resource"/>
<div class="search-suggest">Suggestions for you</div>
</form>
<div class="user">
<form>
<label for="login-email">Insider email</label> <input id="login-email" type="text"/>
</form>
</div>
</section>
<div id="sticky-anchor-nav"></div>
<nav id="sticky-nav" class="main">
<ul class="topnav">
<li><a href="/category/big-data/">Big Data</a>
</li>
<li><a href="/category/cloud-computing/">Cloud Computing</a>
</li>
<li><a href="/category/mobile/">Mobile</a>
</li>
<li><a href="/category/security/">Security</a>
</li>
<li><a href="/category/virtualization/">Virtualization</a>
</li>
</ul>
<ul class="secondary">
<li>
<a href="#" class="hasChildren">Browse by section <span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/news/">News</a></li>
<li><a href="/reviews/">Reviews</a></li>
<li><a href="/videos/">Videos</a></li>
<li><a href="/dealpost/">DealPost</a></li>
<li><a href="/resources/">Resources/White papers</a></li>
</ul>
</li>
<li>
<a href="#" class="hasChildren">Stay connected <span class="ss-icon ss-navigatedown"></span></a>
<ul class="subnav">
<li><a href="/newsletters/signup.html">Newsletters</a></li>
<li><a href="/about/rss.html">RSS</a></li>
</ul>
</li>
</ul>
</nav>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('div.insider-signin').prependTo('section.topics nav.tools');}</script>
<script>$(document).ready(function(){if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav ul li a.hasChildren").attr("href","#").addClass('notMobile');$('nav#sticky-nav ul.secondary').addClass('topnav');}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("nav#sticky-nav > ul").switchClass("topnav","primary");}});</script>
<script>if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#sticky-anchor, section.main, section.topics, section.tools-expand, #sticky-anchor-nav, nav.main').insertBefore($('#banner .ad'));$(document).ready(function(){$('#banner section.tools-expand').addClass('top-margin');});}</script>
</header>
<script>$(document).ready(function(){$('body').addClass('insider-plus');var headerHeight=$('header#banner').height();$('header#banner nav#sticky-nav.main.no-stick').css("top",headerHeight);if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var stickyHeaderHeight=$('section.topics').height()+$('#sticky-head.main').height();stickyHeaderHeight=stickyHeaderHeight-8;}var supportsOrientationChange="onorientationchange"in window,orientationEvent=supportsOrientationChange?"orientationchange":"resize";if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){window.addEventListener(orientationEvent,function(){var top=$('section#sticky-head.main').offset().top;if(top<170){top=0;}else{top=top-50;}if(window.orientation==90||window.orientation==-90){window.scrollTo(0,top);}},false);}if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&$thm.deviceHeight()<768){if($('html').hasClass('touch')){$('#insider-popup.modal-box .modal-body').addClass('short');}else{$('#insider-popup.modal-box .modal-body').addClass('short-desk');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){window.addEventListener(orientationEvent,function(){var top=$('section#sticky-head.main').offset().top;if(top<50){top=5;}else{top=top-40;}if(window.orientation==90||window.orientation==-90){window.scrollTo(0,top);}},false);}var ua=navigator.userAgent.toLowerCase();var isAndroid=ua.indexOf("android")>-1;window.addEventListener(orientationEvent,function(){if(isAndroid&&(screen.width==600||screen.width==960)){location.reload(true);}},false);if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.desktop)&&!$('html').hasClass('touch')){$("ul.social li.more-social").mouseenter(function(){$('ul.social > li').addClass('display-icon');});$("ul.social").mouseleave(function(){$('ul.social > li').removeClass('display-icon');});};if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&$('html').hasClass('touch')){$("ul.social li.more-social").click(function(){$('ul.social > li').toggleClass('display-icon');});};$('.searchbox-input-class').each(function(){$(this).change(function(){var qStr=$(this).val();if($(this).val().indexOf('@')!=-1){qStr=qStr.replace(/@/g,' ');$(this).val(qStr);}});});});function sticky_relocate(){var headerHeight=$('header#banner').height();var winHeight=$(window).height();if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)){winHeight=winHeight-40;if(window.orientation==90||window.orientation==-90){winHeight=winHeight+50;}}else if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)&&!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)){winHeight=winHeight+40;}else{winHeight=winHeight+10;}$('#banner nav#sticky-nav.main').css("height",winHeight);if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var window_top=$(window).scrollTop();var div_top=$('#sticky-anchor').offset().top;if(window_top>div_top){$('#sticky-head').addClass('stick');$('#page-wrapper').addClass('top-pad');$('#banner .ad').addClass('top-margin');}else{$('#sticky-head').removeClass('stick');$('#page-wrapper').removeClass('top-pad');$('#banner .ad').removeClass('top-margin');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('section.topics').addClass('stick-topics');$('#sticky-head').addClass('stick-head');$('#page-wrapper').addClass('top-pad');$('#banner .ad').addClass('top-margin');$('#banner section.tools-expand').addClass('search');var window_top=$(window).scrollTop();var div_top=$('#sticky-anchor').offset().top+30;if(window_top>div_top){$('#sticky-head').addClass('stick');$('.topics.stick-topics, #search-form').addClass('remove');$('li.search-icon').fadeOut("fast");}else{$('#sticky-head').removeClass('stick');$('.topics.stick-topics, #search-form').removeClass('remove');$('li.search-icon').fadeIn("fast");}}if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){if($('#sticky-head').hasClass('stick')){var stickyHeaderHeight=$('section.main').height();stickyHeaderHeight=52;$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').addClass('stick');$('#sticky-nav').removeClass('no-stick');}else{stickyHeaderHeight=$('header#banner').height();$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').removeClass('stick');$('#sticky-nav').addClass('no-stick');}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){var stickyHeaderHeight=$('section.topics').height()+$('#sticky-head.main.stick-head').height();stickyHeaderHeight=stickyHeaderHeight-8;$('header#banner nav#sticky-nav.main').css("top",stickyHeaderHeight);$('#sticky-nav').addClass('stick');if($('#sticky-head').hasClass('stick')){$('#sticky-head.stick').siblings('#sticky-nav').addClass('nav-stick');$('#sticky-head').siblings('#sticky-nav').removeClass('no-stick');}else{$('#sticky-head').siblings('#sticky-nav').removeClass('nav-stick');$('#sticky-head').siblings('#sticky-nav').addClass('no-stick');}}}$(function(){$(window).scroll(sticky_relocate);sticky_relocate();});</script>
<div id="insider-popup" class="modal-box ">
<div class="insider-modal-wrapper">
<div class="modal-header-title">
<div class="modal-banner-insider"><span class="insider"></span></div>
<div class="modal-close close">×</div>
</div>
<div class="modal-body">
<script>$(document).ready(function(){$('a[data-link]').click(function(){var dataLink=$(this).attr('data-link');var toKeep='div[data-link="'+dataLink+'"]';$('div[data-link]').not(toKeep).hide();if($(this).hasClass('link-transition')){$(toKeep).fadeIn(800);}else{$(toKeep).show();}return false;});});</script>
</div>
<div class="modal-footer">
<div class="modal-close close-btn">Close</div>
</div>
</div>
</div>
<script>$(document).ready(function(){var appendthis=("<div class='modal-overlay modal-close'></div>");if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').css({top:10,left:0});}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').height($(document).height());$('.modal-box').css('top','0');}var userAg=navigator.userAgent;$('a[data-modal-id]').click(function(e){e.preventDefault();$('body').append(appendthis);$('.modal-overlay').fadeTo(500,0.9);$('.modal-overlay').height($(document).height());var modalBox=$(this).attr('data-modal-id');if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$('#'+modalBox).fadeIn($(this).data());}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('#'+modalBox).toggle('slide',{direction:'up'},800);}else{$('#'+modalBox).toggle('slide',{direction:'left'},600);}}if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$("html, body").animate({scrollTop:0},700);$('a.btn.continue-on').click(function(){$('html, body').animate({scrollTop:0},500);});return false;}if(navigator.userAgent.match(/(iPad)/)){$("html, body").animate({scrollTop:0},500);}});$(".modal-close, .modal-overlay").click(function(){$('.select2-drop').css('display','none');$(".modal-overlay").fadeOut(500,function(){$(".modal-overlay").remove();});if($(".modal-box").hasClass('triggered')||(userAg.indexOf("Firefox")!=-1)){$(".modal-box").fadeOut(500);}else{if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){$('.modal-box').toggle('slide',{direction:'up'},800);}else{$('.modal-box').toggle('slide',{direction:'left'},600);}}});});</script>
<!-- END PAGE HEADER -->
<div id="page-wrapper" class="page-wrapper">
<div id="skinAdTarget"></div>
<section role="main">
<article itemscope itemtype="http://schema.org/Article">
<div class="ticker-ad ad">
<div id="ticker" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("ticker","true");$('#ticker').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: ticker - [971 1115]");</script>
</div>
<!-- Events Header -->
<!-- //end Events Header -->
<header class='cat'>
<nav class="breadcrumbs horiz">
<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
<li><a href="" itemprop="url"><span itemprop="title"></span></a></li>
</ul>
</nav>
<div class="category"></div>
<h1 itemprop="headline">10 tools to make Kubernetes management easier</h1>
<section class="deck viewability">
<h3 itemprop="description">Take advantage of these third-party projects to simplify Kubernetes app definitions, enhance the CLI and monitoring, and ease AWS cloud deployments</h3>
</section>
<div class="cat-social">
<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">
<li class="sosh">
<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.itworld.com%2Farticle%2F3261450%2Fcontainers%2F10-tools-to-make-kubernetes-management-easier.html&via=itworld&text=10+tools+to+make+Kubernetes+management+easier" target="_blank" onclick="sharingTrack('Twitter-vert', 'twshare')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.itworld.com%2Farticle%2F3261450%2Fcontainers%2F10-tools-to-make-kubernetes-management-easier.html" target="_blank" onclick="sharingTrack('Facebook-vert', 'fblike')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg"/>
</a>
</li>
<li class="sosh">
<a href="http://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.itworld.com%2Farticle%2F3261450%2Fcontainers%2F10-tools-to-make-kubernetes-management-easier.html&title=10+tools+to+make+Kubernetes+management+easier" target="_blank" onclick="sharingTrack('LinkedIn-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/linkedin.svg"/>
</a>
</li>
<li class="sosh">
<a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.itworld.com%2Farticle%2F3261450%2Fcontainers%2F10-tools-to-make-kubernetes-management-easier.html" target="_blank" onclick="sharingTrack('GooglePlus-vert', 'googplus')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/gplus.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww.itworld.com%2Farticle%2F3261450%2Fcontainers%2F10-tools-to-make-kubernetes-management-easier.html&title=10+tools+to+make+Kubernetes+management+easier" target="_blank" onclick="sharingTrack('Reddit-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.itworld.com%2Farticle%2F3261450%2Fcontainers%2F10-tools-to-make-kubernetes-management-easier.html" target="_blank" onclick="sharingTrack('ShareStumbleupPrint-vert')">
<img class="sidecar-icon" src="//idge.staticworld.net/images/stumbleupon.svg"/>
</a>
</li>
<li class="sosh hide">
<a href="#email" id="email-icon">
<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg"/>
</a>
</li>
<li class="sosh hide print">
<a href="javascript:window.print();">
<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg"/>
</a>
</li>
<li class="more">
<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
</li>
</ul>
</div>
<script type="text/javascript">var isValidEmailAddress=isValidEmailAddress||function(emailAddress){var pattern=new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);return pattern.test(emailAddress);};function encodeQueryData(params){var ret=[];for(var paramKey in params){ret.push(encodeURIComponent(paramKey)+"="+encodeURIComponent(params[paramKey]));}return ret.join("&");}function bindEmailModal(){$('#emailModal').on("click",".close-btn",function(event){event.preventDefault();$('#emailModal').hide();$("#emailModal .eml-friend").show();$(".eml-friend-success").hide();$(".eml-friend-error").hide();$('#emailModal').fadeOut(200);$('#email-to').val('');$('#email-from').val('');$('#name').val('');$('#personalization').val('');$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");});$('#emailModal').on("submit","form",function(event){event.preventDefault();var $form=$(this);var action=$form.attr('action');var formData=$form.serialize();var emailFrom=$('#email-from').val();var emailTo=$('#email-to').val();var uresponse=$('#g-recaptcha-response').val();$('#eml-from-address-message').html("");$('#eml-to-address-message').html("");$('#eml-friend-captcha-message').html("");if(isValidEmailAddress(emailFrom)&&isValidEmailAddress(emailTo)&&uresponse!=""){var eloquaParam={AssetCountforCurrentCampaign:"1",AssetName:"",AssetTopic:"",AssetType:"",BuyingCycle:"",C_Address1:"",C_Address2:"",C_BusPhone:"",C_City:"",C_Company_Size1:"",C_Country:"",C_EmailAddress:"",C_FirstName:"",C_Industry1:"",C_Job_Role1:"",C_LastName:"",C_State_Prov:"",C_Zip_Postal:"",ClientName:"",ProgramName:"",brand:"",elqFormName:"CentralRegistrationMasterForm",formId:"3062313",elqSiteId:1856,elqCustomerGUID:elqCustomerGUID,elqCookieWrite:0,friend_email:emailFrom,friend_article_title:"10 tools to make Kubernetes management easier",friend_source:"InfoWorld",friend_article_url:"https://www.itworld.com/article/3261450/containers/10-tools-to-make-kubernetes-management-easier.html",device_platform:navigator.userAgent};$.ajax("https://secure.p01.eloqua.com/e/f2.aspx",{type:'GET',data:eloquaParam,success:function(data,textStatus,xhr){},error:function(xhr,textStatus,errorThrown){}});var eloquaParamMini={elqCustomerGUID:elqCustomerGUID,friend_source:"InfoWorld",device_platform:navigator.userAgent};formData+="&"+encodeQueryData(eloquaParamMini);$.ajax(action,{type:'POST',data:formData,success:function(data,textStatus,xhr){$("#emailModal .eml-friend").hide();$(".eml-friend-success").fadeIn(800);},error:function(xhr,textStatus,errorThrown){$("#emailModal .eml-friend").hide();$(".eml-friend-error").fadeIn(800);}});}else{if(uresponse==""){$('#eml-friend-captcha-message').html("Please verify you're not a robot!");}if(!isValidEmailAddress(emailTo)){$('#eml-to-address-message').html("Please enter a valid email address.");}if(!isValidEmailAddress(emailFrom)){$('#eml-from-address-message').html("Please enter a valid email address.");}}});}$(document).ready(function(){$(document).on("click","#email-icon",function(event){event.preventDefault();bindEmailModal();sharingTrack('Email-vert');$('#emailModal').fadeIn(800);});});</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">
<form class="eml-friend" action="/eloquaemail/article?eloqua=true&id=3261450">
<input type="hidden" name="title" value="10 tools to make Kubernetes management easier"/>
<input type="hidden" name="url" value="https://www.itworld.com/article/3261450/containers/10-tools-to-make-kubernetes-management-easier.html"/>
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Email a friend</h3>
<div class="input-row">
<div id="eml-to-address-message" class="error-msg"></div>
<h4 class="input-label">To</h4>
<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
<p class="addl-text">Use commas to separate multiple email addresses</p>
</div>
<hr/>
<div class="input-row">
<div id="eml-from-address-message" class="error-msg"></div>
<h4 class="input-label">From</h4>
<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
</div>
<div class="input-row">
<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
</div>
<div class="input-row">
<textarea name="message" placeholder="Check out this article I found on ITworld." id="personalization" tabindex="4"></textarea>
</div>
<hr/>
<div class="input-row">
<div id="eml-friend-captcha-message" class="error-msg"></div>
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
<div class="g-recaptcha" data-sitekey="6LczmkcUAAAAANEO7J277KwH6Kzp6BEQjPTWP4S4"></div>
</div>
<hr/>
<div class="submit">
<input type="submit" value="Send" class="input-submit" tabindex="5">
<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
</div>
</form>
<div class="eml-ty eml-friend-success" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Thank you</h3>
<p class="msg-sent">Your message has been sent.</p>
</div>
<div class="eml-friend-error" style="display:none;">
<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
<h3>Sorry</h3>
<p class="msg-sent">There was an error emailing this page.</p>
</div>
</div>
</div>
<div class="cat byline vcard author with-image">
<div class="byline-wrapper">
<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
<a href="/author/Serdar-Yegulalp/" rel="author" title="Serdar Yegulalp"><img class="bylineImage  imgId100354801 " src="https://images.techhive.com/images/article/2014/07/serdaryegulalp2_crop-100354801-byline.jpg" width="34" width="34" alt="Serdar Yegulalp" itemprop="image"/></a>
<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Serdar-Yegulalp/"><span itemprop="name">Serdar Yegulalp</span></a></span>
</p>
<p class="dateline">
Senior Writer,
<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name"><a href="http://www.infoworld.com/" rel="nofollow" target="_blank">InfoWorld</a></span><meta itemprop="logo" content="https://idge.staticworld.net/itw/ITworld-logo300x300.png"/></span> <span class="divider break">|</span>
<span class="pub-date" class='break-date' itemprop="datePublished" content="2018-03-14T03:00-0700">March 14, 2018
</span>
</p>
</div>
</div>
<div class="ad viewability">
<div id="topleaderboard" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("topleaderboard","true");$('#topleaderboard').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topleaderboard - [971 1115]");</script>
</div>
</header>
<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
<meta itemprop="representativeOfPage" content="1"/>
<meta itemprop="height" content="467"/>
<meta itemprop="width" content="700"/>
<img src="https://images.idgesg.net/images/article/2018/01/survival_life-preserver_risk_swimming_rescue-100747102-large.jpg" alt="10 tools to make Kubernetes management easier" itemprop="contentUrl" itemprop="url"/>
<figcaption>
<span class="credit" itemprop="copyrightHolder">
Thinkstock
</span>
</figcaption>
</figure>
<section class="epo cat-narrow stick-rr" id="drr-top-ad">
<div class="ad top-ad">
<div id="topimu" class="adunit ad-container">
</div>
<script type="text/javascript">if($(window).width()>=930){IDG.GPT.addDisplayedAd("topimu","true");$('#topimu').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: topimu - [971 1115]");}</script>
</div>
<!-- Related -->
<div class="related-promo-wrapper">
<div class="promo apart">
<div class="hed">More good reads</div>
<ul class="">
<li class="clearfix with-image">
<a href="/article/3229359/containers/whats-new-in-kubernetes-containers.html"><img class="small.3x2Image  imgId100597897 " src="https://images.techhive.com/images/article/2015/07/containers-100597897-small.3x2.jpg" alt="containers" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3229359/containers/whats-new-in-kubernetes-containers.html">What’s new in Kubernetes containers</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3207686/containers/how-to-get-started-with-kubernetes.html"><img class="carousel.idgeImage  imgId100265449 " src="https://images.techhive.com/images/article/2014/05/old-seasoned-boat-steering-wheel-isolated-on-white-background.-usefull-for-leadership-and-skillful-management-consepts.-94101452-100265449-carousel.idge.jpg" alt="old seasoned boat steering wheel isolated on white background. usefull for leadership and skillful" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3207686/containers/how-to-get-started-with-kubernetes.html">How to get started with Kubernetes</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3251828/application-development/infoworlds-2018-technology-of-the-year-award-winners.html"><img class="small.3x2Image  imgId100748134 " src="https://images.idgesg.net/images/article/2018/01/toy2018-title-100748134-small.3x2.jpg" alt="toy2018 title" itemprop="image"/></a>
<div class="item">
<div class="title"><a href="/article/3251828/application-development/infoworlds-2018-technology-of-the-year-award-winners.html">InfoWorld’s 2018 Technology of the Year Award winners</a></div>
</div>
</li>
<li class="clearfix with-image">
<a href="/article/3256280/software-health/52-off-299-piece-all-purpose-first-aid-kit-deal-alert.html"><img class="small.3x2Image  imgId100750110 " src="https://images.idgesg.net/images/article/2018/02/firstaid-100750110-small.3x2.jpg" alt="firstaid" itemprop="image"/></a>
<div class="item">
<div class="item-eyebrow">DealPosts</div>
<div class="title"><a href="/article/3256280/software-health/52-off-299-piece-all-purpose-first-aid-kit-deal-alert.html">Get a 299-Piece All-Purpose First Aid Kit For $12 Today</a></div>
</div>
</li>
</ul>
</div>
</div>
</section>
<script>if($(window).width()>=930){function debounce(func,wait,immediate){var timeout;return function(){var context=this,args=arguments;var later=function(){timeout=null;if(!immediate)func.apply(context,args);};var callNow=immediate&&!timeout;clearTimeout(timeout);timeout=setTimeout(later,wait);if(callNow)func.apply(context,args);};}$('.related-promo-wrapper').css('visibility','hidden');$(window).load(function(){var drrOffsetTop=$('#drr-top-ad').offset().top;var heroImageHeight=$('figure.hero-img').outerHeight(true);if(heroImageHeight===null){heroImageHeight=0;}var galleryHeight=$('figure.thm-gallery').outerHeight(true);if(galleryHeight===null){galleryHeight=0;}var atAglanceTop=$('.at-a-glance.top').height();if(atAglanceTop===null){atAglanceTop=0;}var atAglanceSingleExpanded=$('.at-a-glance.single.expanded').height();if(atAglanceSingleExpanded===null){atAglanceSingleExpanded=0;}var tickerHeight=$('#ticker').height();var topLeaderHeight=$('#topleaderboard').height();console.log('-----tickerHeight = '+tickerHeight);console.log('-----topLeaderHeight = '+topLeaderHeight);var topAdheight=$('#topimu').height();if(topAdheight<600){$('.ad.top-ad').css('margin-bottom','950px');}var drrContainerHeight=$('div#drr-container').outerHeight(true);console.log('1-----drrContainerHeight = '+drrContainerHeight);drrContainerHeight=drrContainerHeight+heroImageHeight+galleryHeight+atAglanceTop+atAglanceSingleExpanded;console.log('2-----total drrContainerHeight = '+drrContainerHeight);if(window.addEventListener){window.addEventListener('scroll',debounce(function(){var windowtop=(window.scrollY||window.pageYOffset);windowtop=windowtop+60;if(windowtop>=drrOffsetTop){$('#drr-top-ad').addClass('drr-stick');if($("section#sticky-head").length>0){$('#drr-top-ad').addClass('stick-head-pos');}}else{$('#drr-top-ad').removeClass('drr-stick stick-head-pos');}if(windowtop>=1600&&($('.related-promo-wrapper').length>0||$('#drr-top-ad > .insider-promo-wrapper').length>0)){$('.ad.top-ad').fadeOut();}else{$('.ad.top-ad').fadeIn();}if(windowtop>=2800&&($('#drr-mod-0').length>0)){$('.related-promo-wrapper').fadeOut();$('#drr-top-ad > .insider-promo-wrapper').fadeOut();}else{$('.related-promo-wrapper').css('visibility','visible').fadeIn();$('#drr-top-ad > .insider-promo-wrapper').fadeIn();}if(windowtop>=4000&&($('#drr-mod-1').length>0)){$('#drr-mod-0').fadeOut();}else{$('#drr-mod-0, #drr-mod-0 .amzn-native-container').fadeIn();}if(windowtop>=5200){}else{$('#drr-mod-1, #drr-mod-1 .amzn-native-container').fadeIn();}if(windowtop>drrContainerHeight){$('#drr-top-ad').addClass('unstick-drr');$('#drr-top-ad').css({'top':(drrContainerHeight-130)});}else{$('#drr-top-ad').removeClass('unstick-drr');$('#drr-top-ad').css({'top':''});}},5));}});}</script>
<section class="bodee">
<div class="ad placement">
<!--  Begin gpt-skin/inread -->
<div id="inread" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("inread","true");IDG.GPT.displayGoogleTagSlot('inread');</script>
<!--  End gpt-skin/inread -->
</div>
<div class="tocWrapper scaleArticleToc some-toc" data-tracking-category="In-article TOC">
<legend>Table of Contents <i class="ss-navigatedown"></i></legend>
<ul class="articleToc">
<li data-pagenum="1" data-tocnum="1"><a href="#toc-1" class="trackLink">Bitnami Cabin: Kubernetes dashboard for iOS and Android</a></li>
<li data-pagenum="1" data-tocnum="2"><a href="#toc-2" class="trackLink">Kedge: Concise Kubernetes deployment definitions</a></li>
<li data-pagenum="1" data-tocnum="3"><a href="#toc-3" class="trackLink">Koki Short: Manageable Kubernetes manifests</a></li>
<li data-pagenum="1" data-tocnum="4"><a href="#toc-4" class="trackLink">Kube-ps1: Smart Kubernetes command prompt</a></li>
<li data-pagenum="1" data-tocnum="5"><a href="#toc-5" class="trackLink">Kube-prompt: Interactive Kubernetes client</a></li>
<li data-pagenum="1" data-tocnum="6"><a href="#toc-6" class="trackLink">Kube-shell: Shell for the Kubernetes CLI</a></li>
<li data-pagenum="1" data-tocnum="7"><a href="#toc-7" class="trackLink">Kubernetes Ingress Controller for AWS</a></li>
<li data-pagenum="1" data-tocnum="8"><a href="#toc-8" class="trackLink">Kube-ops-view: Dashboard for multiple Kubernetes clusters</a></li>
<li data-pagenum="1" data-tocnum="9"><a href="#toc-9" class="trackLink">Stern: Log tailing for Kubernetes</a></li>
<li data-pagenum="1" data-tocnum="10"><a href="#toc-10" class="trackLink">Teresa: A simple PaaS on Kubernetes</a></li>
</ul>
<div class="toc-show-more">Show More <i class="ss-navigatedown"></i></div>
</div>
<script>var dataLayer=window.dataLayer=window.dataLayer||[];dataLayer.push({'event':'loadInArticleToc'});</script>
<script type="text/javascript">$(document).ready(function(){$('.articleBloxAd').filter(":visible").each(function(index,item){var id=$(item).attr('id');var divClass=$(item).attr('class');var adString=IDG.GPT.getLazyAdCode();$(item).replaceWith("<div id=\""+id+"\" class=\"lazyload_blox_ad "+divClass+"\">"+adString+"</div>");});try{$("div.lazyload_blox_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});}catch(exception){console.log("error loading lazyload_ad "+exception);}});</script>
<script type="text/javascript">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</script>
<div id="drr-container" class='cat ' itemprop="articleBody">
<p>Kubernetes has become a standard way—many would say <em>the</em> standard way — to deploy containerized applications at scale. But if Kubernetes helps us to tame sprawling and complex container deployments, what’s available to help us tame Kubernetes? It too can be complex, messy, and difficult to manage.</p><p>As Kubernetes grows and evolves, it is likely that some of its excesses will be tamed from within. But some people aren’t waiting around for Kubernetes to get any easier to work with, and have rolled their own solutions to many common problems with Kubernetes in production.</p><aside class="fakesidebar"><strong>[ Are you ready for the container invasion? <a href="https://www.infoworld.com/article/3207686/cloud-computing/how-to-get-started-with-kubernetes.html#tk.ifw-infsb">Learn how to get started with Kubernetes</a>. | Keep up with the latest developments in cloud computing with InfoWorld’s <a href="https://www.infoworld.com/newsletters/signup.html#tk.ifw-infsb">Cloud Computing newsletter</a>. ]</strong></aside><p>Here we highlight 10 projects that simplify Kubernetes in various ways, from easing command-line interactions, to simplifying application deployment syntax, to integrating with AWS, to providing a window into multiple clusters.</p><h2 class="toc" id="toc-1">Bitnami Cabin: Kubernetes dashboard for iOS and Android</h2><p>No modern web application or service should be without some kind of mobile interface. <a href="https://github.com/bitnami-labs/cabin" rel="nofollow">Cabin</a> provides Kubernetes admins with a version of the Kubernetes dashboard that is accessible from an iOS or Android smartphone. Many of the functions available in the full Kubernetes dashboard can be launched from Cabin, including Helm charts, scaling deployments, reading pod logs, and accessing web-based apps hosted by Kubernetes.</p><aside class="nativo-promo nativo-promo-1 smartphone" id=""> </aside><h2 class="toc" id="toc-2">Kedge: Concise Kubernetes deployment definitions</h2><p>The most common complaint about Kubernetes is how complex and verbose its manifests, or application definitions, are. They’re a pain to write and a pain to maintain, so it’s little wonder folks turn to third-party tools for relief. <a href="https://github.com/kedgeproject/kedge" rel="nofollow">Kedge</a> offers a simpler, more concise syntax. You provide the simple version of the Kubernetes definition file to Kedge, and Kedge expands it into its full-blown Kubernetes counterpart. Unlike Koki Short (see below), Kedge doesn’t use a modular syntax for its declaration files; it just boils down application definitions to common shortcuts.</p><h2 class="toc" id="toc-3">Koki Short: Manageable Kubernetes manifests</h2><p><a href="https://github.com/koki/short" rel="nofollow">Koki Short</a> — like Kedge above—is a project to improve the way application definitions, or manifests, work in Kubernetes. Like Kedge, Short provides an abbreviated syntax for describing Kubernetes pods that can be translated into the full-blown syntax and back again. Unlike Kedge, Short is also modular, meaning details from one Short declaration can be re-used in others, so that many pods with common elements can be defined succinctly.</p><h2 class="toc" id="toc-4">Kube-ps1: Smart Kubernetes command prompt</h2><p>No, <a href="https://github.com/jonmosco/kube-ps1" rel="nofollow">Kube-ps1</a> isn’t a first-gen Sony PlayStation emulator for Kubernetes (although that <em>would</em> be rather nifty). It’s a simple addition to Bash that displays the current Kubernetes context and namespace in the prompt. Kube-shell includes this along with a great many other things, but if all you want is the smarter prompt, Kube-ps1 provides it with little overhead.</p><h2 class="toc" id="toc-5">Kube-prompt: Interactive Kubernetes client</h2><p>Another minimal but useful modification to the Kubernetes CLI, <a href="https://github.com/c-bata/kube-prompt" rel="nofollow">Kube-prompt</a> allows you to enter what amounts to an interactive command session with the Kubernetes client. Kube-prompt spares you from having to type <code>kubectl</code> to prefix every command, and provides autocomplete with contextual information for each command.</p><aside class="nativo-promo nativo-promo-1 tablet desktop" id=""> </aside><h2 class="toc" id="toc-6">Kube-shell: Shell for the Kubernetes CLI</h2><p>The Kubernetes command line is powerful, but like any command line app it can be tedious to pick through its options. <a href="https://github.com/cloudnativelabs/kube-shell" rel="nofollow">Kube-shell</a> wraps the standard Kubernetes command line in an integrated shell that provides auto-completion and auto-suggestion of common commands, including suggestions provided by the Kubernetes server (e.g., for the names of services). It also gives you a more robust command history function, a <code>vi</code>-style editing mode, and running context information for user, namespace, cluster, and other installation-specific details.</p><h2 class="toc" id="toc-7">Kubernetes Ingress Controller for AWS</h2><p>Kubernetes provides external load balancing and network services to a cluster through a service called <a href="https://kubernetes.io/docs/concepts/services-networking/ingress/" rel="nofollow">Ingress</a>. Amazon Web Services provides load balancing functionality, but doesn’t automatically couple these services to Kubernetes’ facilities for same. The <a href="https://github.com/zalando-incubator/kube-ingress-aws-controller" rel="nofollow">Kubernetes Ingress Controller for AWS</a> closes that gap. The Ingress Controller manages AWS resources for each Ingress object in a cluster automatically, creating load balancers for new ingress resources and deleting load balancers for removed ones, drawing on AWS CloudFormation to ensure the consistent state of the cluster. It also auto-manages other elements used in the cluster like SSL certificates and EC2 Auto Scaling Groups.</p><h2 class="toc" id="toc-8">Kube-ops-view: Dashboard for multiple Kubernetes clusters</h2><p>Kubernetes has a useful dashboard for general-purpose monitoring, but the Kubernetes community is experimenting with other ways to present data usefully to the Kubernetes admin. <a href="https://github.com/hjacobs/kube-ops-view" rel="nofollow">Kube-ops-view</a> is one such experiment; it provides a broad at-a-glance view of multiple Kubernetes clusters, rendered graphically, so one can see at a glance the CPU and memory usage and status of pods across a cluster. It doesn’t allow you to invoke any commands, though; it’s strictly for visualization. But the visualizations it provides are striking and efficient, born for a wall monitor in your operations center.</p><h2 class="toc" id="toc-9">Stern: Log tailing for Kubernetes</h2><p>That’s “stern” as in a ship’s stern, not as in a disciplinarian attitude. <a href="https://github.com/wercker/stern" rel="nofollow">Stern</a> lets you produce color-coded output (as per the <code>tail</code> command) from pods and containers in Kubernetes. It’s a quick way to pipe all the output from these resources into a single stream that can be read at a glance, and provides you with an at-a-glance way (the color coding) to distinguish the streams.</p><h2 class="toc" id="toc-10">Teresa: A simple PaaS on Kubernetes</h2><p><a href="https://github.com/luizalabs/teresa" rel="nofollow">Teresa</a> is an application deployment system that runs as a simple PaaS on Kubernetes. Users, organized into teams, can deploy and manage applications that belong to them. This makes it a little easier for people who are trusted with a given application to work with it, without having to deal with Kubernetes directly.</p>
<p class="orig">This story, "10 tools to make Kubernetes management easier" was originally published by
<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name"><a href="http://www.infoworld.com/" rel="nofollow" target="_blank">InfoWorld</a></span><meta itemprop="logo" content="https://idge.staticworld.net/itw/ITworld-logo300x300.png"/></span>.</p>
<div class="end-note">
</div>
</div>
<script>$("a[data-product-id]").on('click',function(e){var e=e||window.event;var dataLayer=window.dataLayer=window.dataLayer||[];var prodName=$(this).attr("data-product-name");prodName=prodName.replace("\\'","'");if($(this).parents('.slideshow').length>0){var productLinkPosition="Slideshow";}else if($(this).parents('.product-sb').length>0){var productLinkPosition="Product Sidebar";}else if($(this).parents('.at-a-glance.top').length>0){var productLinkPosition="AAG Top";}else if($(this).parents('.at-a-glance').length>0){var productLinkPosition="AAG Bottom";}else if($(this).parents('.product-chart').length>0){var productLinkPosition="Product Chart";}else if($(this).parents('.product-list').length>0){var productLinkPosition="Product List";}else{var productLinkPosition="Body Text";}dataLayer.push({'event':'affiliateLink','eventCategory':'Affiliate Link','eventAction':'Click','eventLabel':''+e.target+'','productVendor':$(this).attr("data-bkvndr"),'productManufacturer':$(this).attr("data-bkmfr"),'productName':prodName,'productId':$(this).attr("data-product-id"),'productLinkPosition':productLinkPosition});});</script>
<script>$("#drr-container a").on('click',function(e){var dataLayer=window.dataLayer=window.dataLayer||[];var $clickEl=$(this);var clickUrl=$clickEl.attr("href");var clickParentsUntilDrr=$clickEl.parentsUntil("#drr-container");var clickText=$clickEl.text().trim();var linkLocation;var linkType;var regex=new RegExp("cio|csoonline|computerworld|itnews|itworld|infoworld|networkworld|javaworld|techconnect|techhive|macworld|pcworld|greenbot|gamestar","i");if(clickParentsUntilDrr.hasClass("fakesidebar")){linkLocation="FSB";}else if(clickParentsUntilDrr.hasClass("end-note")){linkLocation="End Note";}else{linkLocation="Body";}if(regex.test(clickUrl)){linkType="Internal";}else{linkType="External";}dataLayer.push({'event':'editBodyLink','eventCategory':'Editorial Body Links','eventAction':linkType,'eventLabel':linkLocation+" | "+clickText+" | "+clickUrl});});</script>
<div class="apart-alt tags">
<span class="related">Related: </span>
<ul>
<li><a href="/category/open-source-tools">Open Source</a></li>
<li><a href="/category/development">Development</a></li>
<li><a href="/category/cloud-computing">Cloud Computing</a></li>
<li><a href="/tag/kubernetes/" rel="nofollow">Kubernetes</a></li>
<li><a href="/tag/docker/" rel="nofollow">Docker</a></li>
</ul>
</div>
<div class="byline vcard author end-byline">
<div class="author-info">
<p class="bio">Serdar Yegulalp is a senior writer at InfoWorld, focused on machine learning, containerization, devops, the Python ecosystem, and periodic reviews.</p>
</div><!-- end .author-info -->
<div class="brand-social">
<div class="follow-text">Follow</div>
<ul class="social-links">
<li>
<a href="/author/Serdar-Yegulalp/">
<i class="ss-icon ss-user"></i>
</a>
</li>
<li>
<a href="mailto:serdar_yegulalp@infoworld.com">
<i class="ss-icon ss-mail"></i>
</a>
</li>
<li>
<a href="https://twitter.com/syegulalp" class="twitter-follow" target="_blank">
<i class="ss-icon ss-social ss-twitter"></i>
</a>
</li>
<li>
<a href="https://plus.google.com/117543614012474733284" class="googleplus-follow" target="_blank">
<i class="ss-icon ss-social ss-googleplus"></i>
</a>
</li>
<li>
<a href="/author/Serdar-Yegulalp/index.rss" class="rss">
<i class="ss-icon ss-social ss-rss"></i>
</a>
</li>
</ul>
</div>
</div>
<!-- blx4 #1233 blox4.html  -->
<div class="article-intercept">
<a href="https://www.itworld.com/dealpost/">
<i class="ss-icon ss-navigateright"></i><em>ITWorld DealPost: </em>
The best in tech deals and discounts.
</a>
</div>
<script src="/www/js/video/embedder.js"></script>
</section><!-- /.bodee -->
<div id="content-recommender" class="nolinks norewrite">
<div class="head">You Might Like</div>
<div id="rcjsload_66dde9"></div>
<script type="text/javascript">(function(){function ad_block_test(e,o){if("undefined"!=typeof document.body){var t="0.1.2-dev",o=o?o:"sponsorText",n=document.createElement("DIV");n.id=o,n.style.position="absolute",n.style.left="-999px",n.appendChild(document.createTextNode("&nbsp;")),document.body.appendChild(n),setTimeout(function(){if(n){var o=0==n.clientHeight;try{}catch(d){console&&console.log&&console.log("ad-block-test error",d)}e(o,t),document.body.removeChild(n)}},175)}}ad_block_test(function(is_blocked){var widget_id=30207;if(is_blocked===true){widget_id=30283;}var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);var rcel=document.createElement("script");rcel.id='rc_'+Math.floor(Math.random()*1000);rcel.type='text/javascript';rcel.src="//trends.revcontent.com/serve.js.php?w=30207&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth||document.documentElement.clientWidth)+"&referer="+referer+'&is_blocked='+is_blocked;rcel.async=true;var rcds=document.getElementById("rcjsload_66dde9");rcds.appendChild(rcel);});})();</script>
</div>
<div id="amazon-bottom-widget">
<div class="amzn-custom-header">Shop Tech Products at Amazon</div>
<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&storeId=httpwwwidgcsm-20&adInstanceId=b63968b5-f403-435c-9b86-6293250236bb"></script>
</div>
<div class="lazyload_ad">
<code type="text/javascript">
<!--
		document.write('<div id="ciu" class=" ad-container">');
		IDG.GPT.addDisplayedAd("ciu", "true");
		IDG.GPT.addLazyloadedAd("ciu", "true");
		document.write('</div>');
		$('#ciu').responsiveAd({screenSize:'971 1115', scriptTags: []});
		if (Object.keys(IDG.GPT.companions).length > 0 || IDG.GPT.disableInitialLoad) {
			IDG.GPT.refreshAd('ciu');
		}
		//-->
</code>
</div>
<link rel="stylesheet" href="/www.idge/css/sponsored-links.css?v=20180313113117"/>
<link rel="stylesheet" href="/www.idge.itw/css/sponsored-links.css?v=20180313113117"/>
<section id="resources-sponsored-links">
<section class="sponsored-links">
<div class="head">Sponsored Links</div>
<ul class="first">
<li>
<a rel="nofollow" target="_blank" href="http://pubads.g.doubleclick.net/gampad/clk?id=4528403750&iu=/8456/IDG.US_E_ITWorld.com" onclick="moduleTrack('Sponsored Links','resources-sponsored-links component')">
Online Master of Science in Information Systems at Northwestern University
</a>
</li>
</ul>
</section>
</section>
</article>
</section><!-- /role=main -->
</div><!-- /#page-wrapper -->
<link rel="stylesheet" href="/www.idge/css/foot.css?v=20180313113117"/>
<link rel="stylesheet" href="/www.idge.itw/css/foot.css?v=20180313113117"/>
<footer>
<section class="brand" itemscope itemtype="http://schema.org/Organization">
<link itemprop="url" href="http://www.itworld.com">
<a href="/"><span class="logo">ITworld</span></a>
<span class="tagline"> </span>
<span class="follow">
<label>Follow us</label>
<ul>
<li><a href="https://twitter.com/itworld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
<li><a href="http://www.linkedin.com/company/659366" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
<li><a href="https://www.facebook.com/itworld" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>
<li><a href="https://plus.google.com/+ITworld/posts" itemprop="sameAs" rel="publisher" target="_blank" onclick="brandFollowTrack('Google+')"><i class="ss-icon ss-social-circle brand ss-googleplus"></i></a></li>
<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
</ul>
</span>
</section>
<section class="topics">
<nav id="ft1">
<ul>
<li><a href="/category/big-data/">Big Data</a>
</li>
<li><a href="/category/cloud-computing/">Cloud Computing</a>
</li>
<li><a href="/category/mobile/">Mobile</a>
</li>
<li><a href="/category/security/">Security</a>
</li>
<li><a href="/category/virtualization/">Virtualization</a>
</li>
</ul>
</nav>
<nav id="ft2">
<ul>
</ul>
</nav>
<nav id="ft2a">
<ul>
<li><a href="/news">News</a></li>
<li><a href="/resources">Resources</a></li>
<li><a href="/newsletters/signup.html">Newsletters</a></li>
</ul>
</nav>
</section>
<section class="about">
<div class="wrapper">
<nav class="tertiary" id="ft3">
<ul>
<li><a href="/about/about.html">About Us</a>
<li><a href="/about/privacy.html">Privacy Policy</a>
<li><a href="http://www.idgenterprise.com/reach/itworld/" target="_blank" rel="nofollow">Advertising</a>
<li><a href="https://www.idg.com/work-here/" target="_blank" rel="nofollow">Careers at IDG</a>
<li><a href="/about/adchoices.html">Ad Choices</a>
<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a>
</ul>
</nav>
</div>
</section>
<section class="copyright">
<div class="wrapper">
<p><a href="/about/copyright.html">Copyright</a> &copy; 2018 IDG Communications, Inc.</p>
<div class="network">
<div id="network-selector">
<div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
<ul>
<li><a href="https://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
<li><a href="https://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
<li><a href="https://www.csoonline.com" target="_blank" rel="nofollow">CSO</a></li>
<li><a href="https://www.gamestar.com" target="_blank" rel="nofollow">GameStar</a></li>
<li><a href="https://www.greenbot.com" target="_blank" rel="nofollow">Greenbot</a></li>
<li><a href="https://www.idc.com" target="_blank" rel="nofollow">IDC</a></li>
<li><a href="https://www.idg.com" target="_blank" rel="nofollow">IDG</a></li>
<li><a href="https://www.idgconnect.com" target="_blank" rel="nofollow">IDG Connect</a></li>
<li><a href="https://www.idgtechnetwork.com" target="_blank" rel="nofollow">IDG TechNetwork</a></li>
<li><a href="https://www.idg.tv" target="_blank" rel="nofollow">IDG.TV</a></li>
<li><a href="https://www.idgventures.com" target="_blank" rel="nofollow">IDG Ventures</a></li>
<li><a href="https://www.infoworld.com" target="_blank" rel="nofollow">Infoworld</a></li>
<li><a href="https://www.itnews.com" target="_blank" rel="nofollow">IT News</a></li>
<li><a href="https://www.itwhitepapers.com" target="_blank" rel="nofollow">ITwhitepapers</a></li>
<li><a href="https://www.itworld.com" target="_blank" rel="nofollow">ITworld</a></li>
<li><a href="https://www.javaworld.com" target="_blank" rel="nofollow">JavaWorld</a></li>
<li><a href="https://www.linuxworld.com" target="_blank" rel="nofollow">LinuxWorld</a></li>
<li><a href="https://www.macworld.com" target="_blank" rel="nofollow">Macworld</a></li>
<li><a href="https://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
<li><a href="https://www.pcworld.com" target="_blank" rel="nofollow">PCWorld</a></li>
<li><a href="https://www.techconnect.com" target="_blank" rel="nofollow">TechConnect</a></li>
<li><a href="https://www.techhive.com" target="_blank" rel="nofollow">TechHive</a></li>
</ul>
</div><!-- /#network-selector -->
</div><!-- /.network -->
</div><!-- /.wrapper -->
</section>
</footer>
<script src="/www/js/analytics/mouse_down.js"></script>
<script src="/www/js/jquery/jquery-ui.js"></script>
<script src="/www/js/jquery/jquery.dfp.min.js"></script>
<script src="/www.idge/js/mule/shortstack_nav.js"></script>
<div id="mobilewelcomead" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("mobilewelcomead","true");$('#mobilewelcomead').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: mobilewelcomead - [971 1115]");</script>
<script src="/www/js/analytics/tracking.js"></script>
<script src="/www/js/autocomplete.js"></script>
<script src="/www.idge/js/social_sidecar.js"></script>
<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js"></script>
<script src="/www.idge/js/article.js?v=20180313113117"></script>
<script src="/www/js/product-toc.js?v=20180313113117"></script>
<script src="/www/js/prettify.js"></script>
<script src="/www.idge/js/jquery/responsive-tables.js"></script>
<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
<script>$(document).ready(function(){$("table.tablesorter").tablesorter({widgets:['zebra']});$("table.tablesorter tbody tr").hover(function(){$(this).toggleClass("selected");});$("table.tablesorter thead tr th").each(function(){if($(this).find('.ss-icon').length<1){$(this).append('<i class="ss-icon"></i>');}});});</script>
<script src="/www/js/jquery/jquery.lazyload.min.js"></script>
<script src="/www.idge/js/global.js?v=20180313113117"></script>
<script src="/www/js/webfonts/ss-social.js"></script>
<script src="/www/js/webfonts/ss-standard.js"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>
<!-- Begin BlueKai Tag -->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js"></script>
<script type="text/javascript">bk_allow_multiple_calls=true;var blueKaiId=14347;var blueKaiPort=10;var brandCode="itw";var regUrl="https://regdev.idge.int/api/"
var daysToRefresh=30;var bk_debug_log=false;regUrl="https://reg.idgenterprise.com/api/";daysToRefresh=30;if(typeof(s)!='undefined'){bk_addPageCtx("pageType",(typeof(s.pageType)!='undefined')?s.pageType:'');}bk_addPageCtx("cmscatids","[4045,3808,3248,3646,3255]");bk_addPageCtx("cmpy","[]");bk_addPageCtx('tid','6');bk_addPageCtx("purchaseintent","awareness");params=getUrlParams('phint');if(Object.keys(params).length>0){bk_addPageCtx("idg_eid",params['idg_eid']);bk_addPageCtx("newt",params['newt']);bk_addPageCtx("isnl","1");}try{IDG.bkCoreApi.start();}catch(e){bk_doJSTag(blueKaiId,blueKaiPort);if(window.console&&window.console.log){window.console.log("Error Occured While Processing Profile Siubmission")}}$('article, #slideshowCarousel').on('click','.product-list-price, .btn-amazon, .productLink',function(e){var $linkEl=$(e.target);var po=$linkEl.data('po');if($.inArray(po,['amazon','vendor','other'])>=0){if(po=='amazon'){var prCat=$linkEl.data('bkc');if(typeof prCat!='undefined'){bk_addPageCtx('event','AmazonClick'+prCat);}bk_addPageCtx('event','AmazonClickOpenSource');bk_addPageCtx('event','AmazonClickDevelopment');bk_addPageCtx('event','AmazonClickCloudComputing');}var prMfr=$linkEl.data('bkmfr');if(typeof prMfr!='undefined'){bk_addPageCtx('event','eCommerceMFR'+prMfr);}var prVndr=$linkEl.data('bkvndr');if(typeof prVndr!='undefined'){bk_addPageCtx('event','eCommerceClickVendor'+prVndr);}bk_doJSTag(34202,1);}});</script>
<!-- End BlueKai Tag -->
<div id="catfish" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("catfish","true");$('#catfish').responsiveAd({screenSize:'971 1115',scriptTags:[]});IDG.GPT.log("Creating ad: catfish - [971 1115]");</script>
<!--  Begin gpt-skin/inread -->
<div id="gpt-skin" class=" ad-container">
</div>
<script type="text/javascript">IDG.GPT.addDisplayedAd("gpt-skin","true");IDG.GPT.displayGoogleTagSlot('gpt-skin');</script>
<!--  End gpt-skin/inread -->
<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>
<script type="text/javascript">$("div.lazyload_ad").lazyLoadAd({threshold:0,forceLoad:false,onLoad:false,onComplete:false,timeout:1500,debug:false,xray:false});</script>
<script type='text/javascript'>g_arrModules['']=true;g_arrModules['Article Detail:Top:Breadcrumb']=true;g_arrModules['Article Detail:Social Sharing Vertical']=true;$(document).ready(function(){var tocTopper=10;if($('body').hasClass('macworld')||$('body').hasClass('pcworld')||$('body').hasClass('techhive')){tocTopper=0;}$(window).resize(function(){var scaleTocFixBegin=$("#drr-container.cat").offset().top-tocTopper;var scaleTocFixEnd=$(".bodee").offset().top+$(".bodee").height();var scaleTocStartOffsetTop=5;doProductToc(true,false,scaleTocFixBegin,scaleTocFixEnd,scaleTocStartOffsetTop);}).resize();});g_arrModules['']=true;$('#resources-sponsored-links').addClass('show');</script>
<!-- Begin comScore Tag -->
<script>var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"6035308",c3:"",c5:"Open Source",c6:"Article: Feature",c15:"3261450"});(function(){var s=document.createElement("script"),el=document.getElementsByTagName("script")[0];s.async=true;s.src=(document.location.protocol=="https:"?"https://sb":"http://b")+".scorecardresearch.com/beacon.js";el.parentNode.insertBefore(s,el);})();</script>
<noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1"/>
</noscript>
<!-- End comScore Tag -->
<script language="JavaScript" type="text/javascript">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</script>
<!-- SiteCatalyst code version: H.26.2.
Copyright 1996-2013 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->
<script language="JavaScript" type="text/javascript" src="/www.idge/js/analytics/s_code.js"></script>
<script language="JavaScript" type="text/javascript" id="omniVars">g_sOmnitureReportSuite=typeof g_sOmnitureReportSuite!='undefined'&&g_sOmnitureReportSuite?g_sOmnitureReportSuite:"idgitworldcomprod";s.pageName="InfoWorld:article:feature:3261450:10 tools to make Kubernetes management easier";s.pageType="";if(typeof omnitureChannel!='undefined'){s.channel=omnitureChannel;}s.prop1="source:infoworld";s.eVar1="D=c1";s.prop2="content type:feature";s.eVar2="D=c2";s.prop3="display type:article:feature";s.eVar3="D=c3";s.prop4="0 days";s.eVar4="D=c4";s.prop6="";s.prop7="";s.eVar7="D=c7";s.prop9="";s.eVar9="D=c9";s.prop11="published:14-Mar-18";s.eVar11="D=c11";s.prop12="aid:3261450";s.eVar12="D=c12";s.prop13="";s.eVar13="D=c13";s.prop14="author:serdar yegulalp";s.eVar14="D=c14";s.prop15="page number:1";s.eVar15="D=c15";s.prop17="uri:/article/3261450/containers/10-tools-to-make-kubernetes-management-easier.html";s.eVar17="D=c17";s.prop18="";s.eVar18="D=c18";s.prop24=getLoginStatusForOmniture();s.eVar24="D=c24";s.prop28=getTrackingToken('tk')?"tokens:"+getTrackingToken('tk'):"";s.eVar28="D=c28";s.prop37="rpn:itw:feature:infoworld:article:feature:3261450:10 tools to make kubernetes management easier";s.eVar37="D=c37";s.prop39="";s.eVar39="D=c39";s.prop40="";try{s.prop41=IDG.GPT.getDisplayedAds(',')+','+IDG.GPT.getOtherAds(',');s.prop42=IDG.GPT.getModules(',');s.eVar42="D=c42";}catch(e){console.log("error in setting omniture vars: "+e);}s.prop53="";s.eVar53="D=c53";s.prop54="containers,devops,open source,software development,cloud computing";s.eVar30="D=c54";s.eVar33=s.prop55="4045,3808,3248,3646,3255";s.eVar33="D=c55";s.prop56="kubernetes,docker";s.eVar40="D=c56";s.prop61="";s.eVar10="D=c61";s.prop63="awareness";s.prop74="";s.eVar58="D=c74";s.prop75="";s.eVar60="D=c75";s.prop58=":";s.eVar59="D=c58";var sModules='';for(var i in g_arrModules){if(g_arrModules[i]&&i!=''){sModules+=i+',';}}sModules=sModules.replace(/,$/,'');s.prop42=sModules;s.eVar42="D=c42";s.events="";s.events=s.apl(s.events,'event33',',');s.eVar41="14-Mar-18";s.list3=s.prop42+","+s.eVar42;for(var p in s){if(s[p]&&p.match(/^(prop|ceVar)\d+$/)){s[p]=s[p].toLowerCase();}}s.campaign=s.getQueryParam('cid');var s_code=s.t();if(s_code)document.write(s_code)</script>
<script language="JavaScript" type="text/javascript">if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')</script><noscript><img src="http://idgenterprise.d1.sc.omtrdc.net/b/ss/idgitworldcomprod/1/H.25--NS/0" height="1" width="1" border="0" alt=""/></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.26.2. -->
<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
<span id="parsely-cfg" data-parsely-site="itworld.com"></span>
</div>
<script>(function(s,p,d){var h=d.location.protocol,i=p+"-"+s,e=d.getElementById(i),r=d.getElementById(p+"-root"),u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net":"static."+p+".com";if(e)return;e=d.createElement(s);e.id=i;e.async=true;e.src=h+"//"+u+"/p.js";r.appendChild(e);})("script","parsely",document);</script>
<!-- END Parse.ly Include: Standard -->
<script type="text/javascript">$thm.logPlEvent({"b":"itw","e":"view","t":"article","id":"3261450"});</script>
<div id="loginModal"></div>
<div id="logoffModal"></div>
<script type="text/javascript">a=top;f=self;if(a!=f){a.location=f.location;}</script>
</body>
</html>